Heating issues

All Nissan Pulsar related discussions
Post Reply
Mrsemcee
Posts: 3
Joined: Fri Mar 22, 2019 2:48 pm

Heating issues

Post by Mrsemcee » Fri Mar 22, 2019 2:58 pm

Hi guys,

New to the forum and really hoping to get some help if possible. I regrettably bought a 2015 Nissan Pulsar Tekna Dig-T xtronic. It’s just been one problem after another and I can’t return it as I just missed the 6mnth cut off. Since September, I’ve done to buy a new battery and have topped up over 5l of oil (5W30).

Latest problem is the heating won’t work which means clearing the windscreen is hell. It’ll only clear if the a/c is on and in this weather makes driving unbearably cold. Occasionally the heating kinda works but only after about 10-15 mins driving and only if it hasn’t been too cold. Mechanic put it on the machine and an a/c fault came up but he’s at a loss as to what could be wrong and is recommending I take it to Nissan.

Has anyone else experienced this problem please?


fujikun
Posts: 67
Joined: Fri May 04, 2018 12:41 pm

Re: Heating issues

Post by fujikun » Fri Mar 22, 2019 3:24 pm

sounds like a stuck thermostat, are your electric cooling fans on? i wouldnt think its a blocked radiator, you dont say the mileage.
5litres of oils a lot you either have a leak or burning it.
if the cooling system has an airlock the heater can stop working but the coolant would had have to have been drained and not refilled correctly for this, and unless you know the history?
is that the 1.6 engine?


Swe
Posts: 84
Joined: Sun Nov 06, 2016 10:37 am
Location: Sweden

Re: Heating issues

Post by Swe » Fri Mar 22, 2019 5:18 pm

Oil consumption and xtronic means 1,2 l engine. I've had a coolant leakage at the housing of the cooling thermostat. The housing was cracked and a lot of coolant fluid was lost. This caused air in the heating element, maybe something similar has hapend to you??
:shock:


Mrsemcee
Posts: 3
Joined: Fri Mar 22, 2019 2:48 pm

Re: Heating issues

Post by Mrsemcee » Fri Mar 22, 2019 6:07 pm

Thank you both. It’s a 1.2 and 17500 onbtgw clock. Was previously owned on the mobility scheme. It’s got fsh and no mention of any issues with a/c or themostat. If the problem is what either of you say wouldn’t that stop the a/c working? Aldi, when I think about the fans on the dash barely blow any air.


Mrsemcee
Posts: 3
Joined: Fri Mar 22, 2019 2:48 pm

Re: Heating issues

Post by Mrsemcee » Fri Mar 22, 2019 6:13 pm

Just checked with mechanic and it’s deffo not the thermostat or leaking coolant. He thinks it could be something wrong with a sensor as the radiator gets hot or something like that. Didn’t really understand the jargon.


Swe
Posts: 84
Joined: Sun Nov 06, 2016 10:37 am
Location: Sweden

Re: Heating issues

Post by Swe » Sat Mar 23, 2019 7:49 am

Fan working with manual button? The outdoor sensor temp show correct temp?? Look at display. Try to set ACC in off mode, set max temp/heat, fan to max, drive for15 min, any heat from vents??
:shock:


Post Reply

Return to “Main Nissan Pulsar chat”