Trouble keeping car running

All Nissan Pulsar related discussions
Post Reply
Unhappy pulsar owner
Posts: 2
Joined: Mon Jun 22, 2020 11:32 am

Trouble keeping car running

Post by Unhappy pulsar owner » Mon Jun 22, 2020 11:48 am

I have a 94 model Nissan pulsar N14 2l twin cam’ it is automatic
There has been one problem after another and has been expensive to locate the problem still with no success
Car will start but runs very rough
Will cut out randomly when driving
Go to kick it over and doesn’t start up straight away’
Normally 4 or more attempts at starting it will fire up
An start to run
Than it will die again as u get couple klms down the road
Kick it over again accelerate drop in drive before it cuts out again an start driving away before it dies on you again’ Have had a number of things changed’
Leads’ spark plugs new battery
Distributor cap’ rotor button’ crank angle sensor’
Fuel filter’ ignition coil’ Few more things have been replaced can’t remember off hand cause there is to many to keep track of
Been to 4 auto electricians and none have been able to locate the problem

Metalmickey
Posts: 163
Joined: Tue Jul 12, 2016 8:55 pm

Re: Trouble keeping car running

Post by Metalmickey » Mon Jun 22, 2020 7:20 pm

this forum is for the nissan pulsar C13 model, only started production in 2014.

PulsarNismo94
Posts: 45
Joined: Tue Nov 26, 2019 12:45 am

Re: Trouble keeping car running

Post by PulsarNismo94 » Mon Jun 22, 2020 11:08 pm

It is the wrong forum but, try checking all the vacuum lines. It's common for them to crack on an old car and this sounds like a vac leak
Nissan Pulsar 1.6 Dig-T '15

Unhappy pulsar owner
Posts: 2
Joined: Mon Jun 22, 2020 11:32 am

Re: Trouble keeping car running

Post by Unhappy pulsar owner » Tue Jun 23, 2020 12:01 am

Ok thanks I’ll look into this

Post Reply